#17969 closed Bugs (Fixed)

[Mac] [Leia Alpha 2] Full screen on different monitor broken

Reported by: noels_77 Owned by: Memphiz
Priority: 4 - Normal
Component: Mac OS X specific feature Version: 18.0 "Leia" Alpha1
Severity: Normal Keywords: Mac, Full Screen, Leila
Cc: Memphiz, FernetMenta Blocked By:
Blocking: Platform: OS X

Description

Attempt to set Kodi in Full Screen on a secondary Monitor is broken. The application goes in full screen but the image is not resized as expected (see image attached).

This is a regression introduced in Leila Alpha 2, Alpha 1 works perfectly.

The same issue is visible also in the night build (at least in the one from 21 July).

Attachments (1)

Screen Shot 2018-07-21 at 17.12.08 (2).png (418.7 KB) - added by noels_77 at 2018-07-21T17:12:59+01:00.
Full screen image

Change History (14)

Changed at 2018-07-21T17:12:59+01:00 by noels_77

Full screen image

comment:1 Changed at 2018-08-01T21:04:40+01:00 by noels_77

Folks, I noticed the same bug is still affecting Alpha 3.

comment:2 follow-up: Changed at 2018-08-02T16:24:18+01:00 by Rechi

Debug Log is missing.

comment:3 in reply to: ↑ 2 Changed at 2018-08-05T15:25:20+01:00 by noels_77

Replying to Rechi:

Debug Log is missing.

I appreciated that but just to let you know it's an issue 100% reproducible.

1) Run Kodi (Leia alpha 3) while your Mac (in my case a Macbook 2018) is connected to an external monitor

2) Move the Kodi's window in the second monitor

3) Press the green button to switch in full screen.

Perhaps Memphiz may be able to help on this.

Last edited at 2018-08-05T15:26:28+01:00 by noels_77 (previous) (diff)

comment:4 Changed at 2018-08-05T15:44:27+01:00 by Rechi

  • Component changed from > Choose specific component to Mac OS X specific feature
  • Owner set to Memphiz

comment:5 follow-up: Changed at 2018-08-05T17:01:39+01:00 by Memphiz

That green button for going to fullscreen is not supported in our code and worked by accident if even. Latest changes to multi monitor code might have changed behaviour to what you see now. The official way for switching to fullscreen is via kodi settings - system - display.

Let us know if the official way behaves correct.

comment:6 in reply to: ↑ 5 Changed at 2018-08-05T18:14:00+01:00 by noels_77

Replying to Memphiz:

That green button for going to fullscreen is not supported in our code and worked by accident if even. Latest changes to multi monitor code might have changed behaviour to what you see now. The official way for switching to fullscreen is via kodi settings - system - display.

Let us know if the official way behaves correct.

Thanks Menphiz for your answer.

I tested the case you suggested and the situation is much worse: when I attempt to switch on full screen on the second monitor both monitors start blinking forever and the only way to fix it is to kill Kodi from the terminal. Switching on full screen on the main monitor works (and it works also via the "green button").

I would say everything just worked before Leia Alpha 2 (Leia Alpha 1 and previous version of Kodi works like a charm) so I would say this is a regression that has been introduced between Leia Alpha 1 (I currently use that and it works perfectly) and Leia Alpha 2.

If you need further info/logs please let me know.

comment:7 Changed at 2018-08-05T19:55:21+01:00 by Memphiz

  • Cc FernetMenta added

@FernetMenta - can you reproduce that?

comment:8 Changed at 2018-08-06T14:56:58+01:00 by FernetMenta

@Memphiz, yes i can. The problem is that we get too many WindowChangedScreen events. Before getting the one for the new monitor, we get one for the screen we left. this makes the kodi window switching back and forth. We need to find a way to ignore the event for the old screen.

comment:11 Changed at 2018-08-09T23:36:55+01:00 by noels_77

@Memphiz and @FernetMenta many thanks for that.

I'm on holiday at the moment and I don't have a second monitor to test this fix. I will be able to give you feedback about this issue next week.

comment:12 Changed at 2018-08-14T15:11:37+01:00 by noels_77

@Memphiz and @FernetMenta I can confirm the fix resolves completely the issue. Many thanks for that.

comment:13 Changed at 2018-08-14T15:20:45+01:00 by FernetMenta

  • Milestone changed from Pending / Future to 18.0 "Leia"
  • Resolution set to Fixed
  • Status changed from new to closed

thanks for confirming

Note: See TracTickets for help on using tickets.