#17915 closed Bugs (Invalid)

Busy Dialog related crashes with Music Folder and ORF TVthek addon

Reported by: HiassofT Owned by: mkortstiege
Priority: 4 - Normal
Component: Graphical User Interface (GUI) Version: 18.0 "Leia" Alpha1
Severity: Normal Keywords: busy dialog crash
Cc: FernetMenta Blocked By:
Blocking: Platform: Linux

Description

I initially noticed the "Play All" function of the ORF TVthek addon crashing Kodi on recent RPi2 Milhouse and LibreELEC master builds, the same crashes are reproducible on kodi master / Linux x86_64 (Debian Stretch).

I also noticed choosing "Play" (from the context menu) on a music folder also crashes kodi - both on Milhouse and Linux.

Test setup: kodi githash 44f7cc9ec3 (2018-06-12 06:59:59 +0100) on Debian Stretch, ORF TVthek addon from the Kodi repository (version 0.8.3), a single directory of MP3 files (scanning into library is not necessary).

Reproducing ORF TVthek crash:

  • choose "Recently Added Shows"
  • select one of the "ZIB" news entries
  • select "[Play all]" from the beginning of the list

Kodi log: http://ix.io/1d5R Kodi stacktrace: http://ix.io/1d5S

Reproducing Music folder crash:

  • add some music source (I chose $HOME/Music), scanning into library is not necessary
  • choose Music -> Files
  • navigate to a folder with music files
  • open context menu and choose "Play"

Kodi log: http://ix.io/1d5W Kodi stacktrace: http://ix.io/1d5X

I'm not sure if these two issues are related, but both stacktraces of the crashing thread showed that CGUIDialogBusy::WaitOnEvent() was invoked two times, with the second invocation leading to the crash

Change History (9)

comment:1 Changed at 2018-06-13T18:18:55+01:00 by ronie

  • Cc FernetMenta added

cc FernetMenta in case it's related to your recent busy dialog changes.

comment:2 Changed at 2018-06-13T18:42:16+01:00 by FernetMenta

the root cause is that the addon marks single items like [play all] as folders. This results is double action: 1) updating items for the folder 2) exec script and playback for item/folder

comment:3 Changed at 2018-06-13T19:15:46+01:00 by HiassofT

Version 0.8.2 of the ORF TVthek addon contained patches from Rechi and wsnipex to fix the folder issue. I did some tracing and it looked like play all was not marked as a folder. Could well be that I missed something though.

I've asked them and the addon author to chime in here.

comment:4 Changed at 2018-06-13T20:59:40+01:00 by sofaking

0.8.3 doesnt mark the playall item as folder(0.8.2 didnt have that fix yet) another problem with the fix is that it caused an endless loop leading to a kodi crash for kodi 17.6 but also for kodi 18 alpha1.

comment:5 Changed at 2018-06-13T21:05:36+01:00 by HiassofT

Sorry, had a typo in my last comment, that should have read 0.8.3, not 0.8.2

comment:6 Changed at 2018-06-15T05:45:57+01:00 by FernetMenta

The addon calls playPlaylist in a recursion. The first call waits in CPluginDirectory::GetPluginResult and while waiting the addon calls playPlaylist and we get into CPluginDirectory::GetPluginResult a second time

comment:7 Changed at 2018-06-18T11:05:27+01:00 by HiassofT

A quick test with Milhouse build 0617 on RPi3B+ indicates that music folder playback seems to be fine now.

Using play all in the ORF TVthek addon still crashes kodi though.

I'm leaving this ticket open for now, even if the ORF TVthek addon needs fixing Kodi shouldn't just crash.

Last edited at 2018-06-18T11:05:53+01:00 by HiassofT (previous) (diff)

comment:8 Changed at 2018-06-19T16:17:36+01:00 by HiassofT

With ORF TVthek addon 0.8.5 kodi no longer crashes.

So both reported issues have been resolved and the ticket can be closed.

comment:9 Changed at 2018-06-19T16:18:39+01:00 by ronie

  • Milestone Pending / Future deleted
  • Resolution set to Invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.