#17913 new Bugs

Music Playback in "Party Mode" fails

Reported by: DaveBlake Owned by: FernetMenta
Priority: 4 - Normal
Component: Audio playback (audio/video files) Version: 18.0 "Leia" Alpha1
Severity: Normal Keywords: party mode, busydialog
Cc: Blocked By:
Blocking: Platform: All

Description

As reported by a user on the forum here https://forum.kodi.tv/showthread.php?tid=332688 since nightly 20180601-7831ed96 party mode does not work.

The issue is related to the changes in busydialog, as prior to https://github.com/xbmc/xbmc/pull/13954 it works as expected. Checked using Git bisect.

To reproduce: Scan some music files into the music library (if not already have items in the library). Go to the music library window (any node will do, says artists or albums). Pull out the sideblade menu and click on "party mode"

What happens: The "Filling glasses" message is displayed (briefly) The playlist is populated and playback starts, but the busy dialog continues to show. This can not be cancelled. After some time, possibly on changing to next track, Kodi will crash.

Debug log https://pastebin.com/bgr0uhTg (from user)

https://pastebin.com/39aC00Gk (from da-anda)

There is a possible dependancy on how many songs there are in the music library, and/or if the node currently on display is being displayed for the first time or has been cached. These are things that would make population of the fileitem list slower.

In my own testing I could get this failure to occur 9 times out of 10, but on the odd time party-mode worked.

Change History (3)

comment:1 Changed at 2018-06-12T10:22:51+01:00 by DaveBlake

  • Component changed from > Choose specific component to Audio playback (audio/video files)
  • Milestone changed from Pending / Future to 18.0 "L*****"

comment:2 Changed at 2018-06-12T10:32:56+01:00 by DaveBlake

From further testing it seems to become harder to repeat this failure once you have been using Kodi for a while, or on restarting. I have not been able to determine what the contributing factors are.

When bisecting, hence new build every time but existing databases etc., I reproduced the fault every time. Now, repeat runs of the same build, it only has an issue some of the times. Sometimes is crashes, but others it just hangs showing the busy dialog and I can use the keyboard to shutdown.

comment:3 Changed at 2018-08-08T20:32:09+01:00 by Martijn

  • Milestone changed from 18.0 "L*****" to 18.0 "Leia"

Milestone renamed

Note: See TracTickets for help on using tickets.