#17656 reopened Bugs

Dropped frames caused by subtitle rendering

Reported by: Haohmaru Owned by: FernetMenta
Priority: 4 - Normal
Component: Video playback (inc. audio in video and codecs) Version: 18.0 "Leia" Alpha1
Severity: Normal Keywords: subtitle, aml
Cc: peak3d Blocked By:
Blocking: Platform: Other

Description (last modified by Haohmaru)

Hello !

Playing videos with subtitles enabled causing dropped frames.

Please check the sample and Debug Log I've uploaded.

I was using Libreelec [8.90.4] on a Minix U9 ( S912 ) but it's very important to note that the bug can be reproduced on Krypton too using other ( non Amglogic ) hardware as well. The bug was reported already confirmed by the Libreelec developer kszaq but the conclusion was that Team-Kodi don't look into v17 issues anymore only v18. That is why I would like to get some attention here with this ticket to point out that it's still exist in Leia.

Thank you for looking into it.

Change History (14)

comment:1 Changed at 2017-11-19T10:52:07Z by Haohmaru

  • Description modified (diff)

comment:2 Changed at 2017-11-19T12:18:42Z by Haohmaru

  • Description modified (diff)

comment:3 Changed at 2017-11-19T13:35:21Z by FernetMenta

  • Cc peak3d added
  • Keywords aml added
  • Platform changed from All to Other

I tried the sample and don't observe any issues on the reference platform: OpenGL. AML is totally different because the aml decoder bypasses Kodi's UI rendering and outputs video to a separate video plane.

@peak3d, you might want to look at this

comment:4 Changed at 2017-11-19T14:18:00Z by FernetMenta

  • Summary changed from Dropped frames causes by subtitle rendering to Dropped frames caused by subtitle rendering

comment:5 Changed at 2017-11-20T13:54:03Z by peak3d

  • I tested the sample movie with subtitles visible on odroid-C2.

For this test I added the drop:0/1 log item to RenderUpdate log line.

I played the movie 3 times (latest kodi master) without any drop, but on a 60hz monitor (no 23.9 capabable device available.

  • From debug log it seems to be kszaq's LE build wich is modified regarding AML video pipeline in many places. Because of this I suggest that you place the issue in LE forum / or directly in kszaq's git branch.

comment:6 Changed at 2017-11-20T13:57:43Z by peak3d

  • Resolution set to Can not replicate
  • Status changed from new to closed

comment:7 Changed at 2017-11-22T07:33:00Z by peak3d

  • Resolution Can not replicate deleted
  • Status changed from closed to reopened

comment:8 Changed at 2017-11-22T07:39:29Z by peak3d

Can you pls. ask in LE Forum how to set the GPU Governor and set it to something High like Perfrmance? From what you tell it seems that waking up GPU clock could lead to the issues.

kszaq should be able to track the issue, 80% of the log lines in your log are not vanilla kodi, so he's playing around there. If he modifies the code, he should be able to support this issue.

We can do one more try here: please activate avsync component logging in kodi logging options and then play again and provide the log, thx!

comment:9 Changed at 2017-11-22T18:45:39Z by Haohmaru

OK here is the log. But something is wrong. It seems that if I enable debug logging no matter if subs are enabled or disabled I get some stuttering. (Is it happening because I'm booting Kodi from a USB drive ?)

Without the debug log I only get dropped frames with subtitles on. It's smooth without it. And I still can't belive that the problem is immediately fixed as long as codecinfo (PlayerDebug) is up. This must be something utilizable to fix the stuttering !

Please tell me if I can assist further.

Last edited at 2017-11-22T18:46:13Z by Haohmaru (previous) (diff)

comment:10 Changed at 2017-11-22T18:51:43Z by FernetMenta

You should enable debug logging in advanced settings to avoid having the debug info on screen.

comment:12 Changed at 2017-11-22T20:08:15Z by peak3d

@Haohmaru can you pls. play the video on 60hz monitor and tell if issue is still present?

comment:13 Changed at 2017-11-22T20:21:38Z by Haohmaru

I don't have an HDMI input sadly on my PC monitor but when I play the sample with "adjust display resfresh rate" off on my LG OLED55C7 set to 60Hz then the stuttering is almost non existent. I think the frame drops in this case are simply there because I play 23.976 material on 60hz.

Last edited at 2017-11-22T20:22:10Z by Haohmaru (previous) (diff)

comment:14 Changed at 2017-11-27T16:54:16Z by kszaq

@peak3d Just for a note: this user is not using my build, I don't provide any build with Kodi v18.

Logs here come from some community build for S912 which uses libhybris to render the GUI and in my opinion the bug has to be reproduced on a device with proper GPU drivers, i.e. S905(X) to be looked into.

Note: See TracTickets for help on using tickets.