#17299 closed Bugs (Fixed)

DVD ISO with menu won't play

Reported by: DaVu Owned by: FernetMenta
Priority: 4 - Normal
Component: Video playback (inc. audio in video and codecs) Version: 17.0 "Krypton" RC3
Severity: Normal Keywords: DVD ISO playback
Cc: Blocked By:
Blocking: Platform: All

Description (last modified by DaVu)

Try to play a DVD ISO (full rip with menus) and it won't play at all.

There is nothing mentioned like "unplayable item....check log". It just don't start.

The same file plays well on VLC including the menu.

Kodi debug log: http://paste.ubuntu.com/23925115/

I still am able to move the mouse and after clicking on the screen Kodi will look like this:

http://imgur.com/a/QOOjJ

After ripping the DVD to MKV the movie plays fine. So I would say it's the menu which is causing the issue. But you will know best ;)

Greetings.

Change History (23)

comment:1 Changed at 2017-02-04T13:21:35Z by DaVu

  • Description modified (diff)

comment:2 Changed at 2017-02-05T05:38:58Z by folken

The DVD is equipped with Disney fast play. At a guess it's somehow related to the issue.

comment:3 Changed at 2017-02-05T05:43:57Z by folken

More info, it plays fine on Kodi Javis 16.1

comment:4 Changed at 2017-04-07T16:52:39+01:00 by pixeluk

Just add I've found the same problem although in my case the DVD's are stored in folder structure rather than ISO. As has been pointed out it's not all DVD's and so far I've had the problem with a couple of Lego Friends TV DVD's (each has three episodes). The studio intro plays fine followed by a blank screen although the menu music plays fine. Pressing OK selects the first menu option (blind) and the DVD episode then plays fine - it's just the menu that has a blank screen. Playing the same DVD with Jarvis 16.1 is fine.

comment:5 Changed at 2017-04-09T11:29:19+01:00 by pixeluk

Just to add that the problem also occurs running 17.1 on a 1st gen FireTV so appears to be irrespective of the hardware.

comment:6 Changed at 2017-04-09T12:01:10+01:00 by FernetMenta

please provide a sample to reproduce the issue.

comment:7 Changed at 2017-04-13T15:34:56+01:00 by pixeluk

A sample being a full DVD rip? how would you like me to provide this? the smallest DVD I can find with the problem is 2.7GB

comment:8 Changed at 2017-04-13T16:29:33+01:00 by FernetMenta

Only a small part of the entire DVD is needed, if the issue is in the menus. I am not an expert on how to do this but I already got quite of a few of those stipped down ones for debugging.

Last edited at 2017-04-13T16:29:51+01:00 by FernetMenta (previous) (diff)

comment:9 Changed at 2017-04-14T15:27:04+01:00 by folken

Hello

http://www.wafreenet.org:1981/html/beast.iso

Please find above a link to download the menu only to demonstrate the issue

T

comment:10 Changed at 2017-04-14T17:33:08+01:00 by FernetMenta

I don't observe any issues with this sample on my system with my dev version. did you try with hw acceleration disabled?

comment:11 Changed at 2017-04-15T04:14:41+01:00 by folken

I did try with hw acceleration disabled. Can you confirm if your running kodi on linux or windows? it appears to play on kodi for windows but not linux. Simple way to replicate the issue is to install libreelec

T

comment:12 Changed at 2017-04-15T06:40:55+01:00 by FernetMenta

I tested on OSX. Be aware the LE is not vanilla Kodi. They carry a lot of custom patches

comment:13 Changed at 2017-04-15T07:02:02+01:00 by DaVu

@fernetmenta

I also downloaded the iso above and tested with Kodi 17.1 on Ubuntu 16.04. I used the filemanager to start the playback (open context, selected "play with" -> "Video Player (default)"). I see some green "play" arrow appearing at the top but I don't see the menu coming up.

Here is the log: http://paste.ubuntu.com/24385149/

comment:14 Changed at 2017-04-15T07:14:22+01:00 by FernetMenta

@DaVu, can you disable vdpau and try again?

You could also try this: https://github.com/xbmc/xbmc/pull/11946

I think the issue is already fixed with those updates.

comment:15 Changed at 2017-04-15T08:32:23+01:00 by DaVu

@fernetmenta:

this is with VPDAU disabled. Still no luck: http://paste.ubuntu.com/24385451/

Regarding to the GH link....do you want me to build Kodi from source applying those patches? I can't do that...I would need some help to cherrypick them or to compile from source. It's not impossible to me, but it requires some help, tbh.

If Kodi 18 is available at the nightlies repo and if those patches are already included in those nightlies, I'm fine to use that even if Kodi crashes for some reasons ;).

comment:16 Changed at 2017-04-15T09:22:09+01:00 by FernetMenta

@DaVu the easiest approach is to build the vpupdates branch. This branch is on the main repo so just "git checkout vpaudates", then build kodi.

comment:17 Changed at 2017-04-15T14:55:44+01:00 by DaVu

@fernetmenta:

got compilation managed.

Confirming that it works with that version. In case you need a log:

https://paste.ubuntu.com/24387022/

comment:18 Changed at 2017-04-17T01:42:55+01:00 by folken

does that mean this bug is fixed?

comment:19 Changed at 2017-04-17T06:34:59+01:00 by DaVu

That means this bug is fixed for Kodi 18 at least. Not sure if the changes will be backported to Kodi 17.x (maybe 17.2).

@fernetmenta is able to answer that.

comment:20 Changed at 2017-04-17T10:12:14+01:00 by FernetMenta

There are a lot of API changes in this vpupdates branch. Spottting this particular fix and trying to backport it would take some time. Personally I don't have enough time to do this. I have been working on v18 for half a year now.

comment:21 Changed at 2017-04-17T14:46:40+01:00 by folken

Thank you very much FernetMenta, your time in fixing this issue is very much appreciated. Feel free to close this ticket as resolved. I'll await the arrival of Kodi 18

comment:22 Changed at 2018-05-09T21:27:52+01:00 by Rechi

  • Milestone changed from Pending / Future to 18.0 "L*****"
  • Resolution set to Fixed
  • Status changed from new to closed

comment:23 Changed at 2018-08-08T20:32:09+01:00 by Martijn

  • Milestone changed from 18.0 "L*****" to 18.0 "Leia"

Milestone renamed

Note: See TracTickets for help on using tickets.