#16876 closed Bugs (Fixed)

3D broken - Picture is too small

Reported by: Kopierwichtel Owned by: FernetMenta
Priority: 4 - Normal
Component: Video playback (inc. audio in video and codecs) Version: 17.0 "Krypton" Beta3
Severity: Normal Keywords:
Cc: afedchin, da-anda Blocked By:
Blocking: Platform: Windows

Description

I installed Kodi (17.0-BETA2 Git:20160901-ae5fc7c) on my Windows 7 Maschine and wanted to Play one of my existing Full SBS 3D Videos.

When playing the height of the Video is not correct. It seems to be the half of the correct height

I attached the latest logs and a media info report

Attachments (8)

kodi.log (422.4 KB) - added by Kopierwichtel at 2016-09-02T22:06:09+01:00.
Zootopia.html (12.3 KB) - added by Kopierwichtel at 2016-09-02T22:10:45+01:00.
2016-09-03 14_13_09-Kodi.jpg (196.6 KB) - added by Kopierwichtel at 2016-09-03T13:23:07+01:00.
2016-09-06 19_43_55-Kodi.jpg (395.3 KB) - added by Kopierwichtel at 2016-09-06T18:51:11+01:00.
Sample.mkv (1.2 MB) - added by Kopierwichtel at 2016-10-15T23:22:35+01:00.
Sample from my DB
kodi.2.log (249.4 KB) - added by Kopierwichtel at 2016-10-18T19:28:25+01:00.
screenshot000.jpg (406.8 KB) - added by Kopierwichtel at 2016-10-19T20:03:52+01:00.
after switching to 3D mode
screenshot001.jpg (395.9 KB) - added by Kopierwichtel at 2016-10-19T20:04:26+01:00.
after closing and reopening the on screen menu

Change History (30)

Changed at 2016-09-02T22:06:09+01:00 by Kopierwichtel

Changed at 2016-09-02T22:10:45+01:00 by Kopierwichtel

comment:1 Changed at 2016-09-03T10:45:09+01:00 by Martijn

  • Cc afedchin added

comment:2 Changed at 2016-09-03T13:21:55+01:00 by Kopierwichtel

added a screenshot.

In the MKV the Video Display res is set to 1920x800 The real res is 3840x800

Changed at 2016-09-03T13:23:07+01:00 by Kopierwichtel

comment:3 Changed at 2016-09-06T08:05:32+01:00 by FernetMenta

  • Cc da-anda added

@da-anda, any idea?

comment:4 Changed at 2016-09-06T18:50:27+01:00 by Kopierwichtel

I copied the video used mkvtoolnix to change the Video Display height to 1600, then the picture has the correct ratio (see attachment).

In Kodi the height is changed to 1600. in VLC player its set to its original value 800.

Changed at 2016-09-06T18:51:11+01:00 by Kopierwichtel

comment:5 Changed at 2016-10-06T18:10:36+01:00 by Kopierwichtel

I updated to Beta 3 and the issue still exists.

comment:6 Changed at 2016-10-08T13:29:50+01:00 by Martijn

  • Severity changed from Major to Normal

comment:7 Changed at 2016-10-08T14:15:17+01:00 by Martijn

  • Milestone changed from 17.0 "Krypton" to Future / Pending
  • Version changed from 17.0 "Krypton" Beta2 to 17.0 "Krypton" Beta3

comment:9 Changed at 2016-10-15T09:19:02+01:00 by FernetMenta

could you please provide a sample to reproduce

comment:10 Changed at 2016-10-15T10:52:50+01:00 by FernetMenta

  • Milestone changed from Pending (DO NOT CHANGE) to 17.0 "Krypton"

Changed at 2016-10-15T23:22:35+01:00 by Kopierwichtel

Sample from my DB

comment:11 Changed at 2016-10-16T07:04:44+01:00 by FernetMenta

  • Resolution set to Fixed
  • Status changed from new to closed

fix was merged

comment:12 Changed at 2016-10-18T17:39:15+01:00 by Kopierwichtel

I updated to 20161017-3067744 but its not yet working. Is the fix already included in this version?

comment:13 Changed at 2016-10-18T17:48:46+01:00 by FernetMenta

Yes and the sample you provided did work on my machine. Please post a new debug log.

comment:14 Changed at 2016-10-18T17:50:41+01:00 by Martijn

Today's build failed for some reason so I'm kicking new build to be sure and will link it here

comment:16 Changed at 2016-10-18T19:27:45+01:00 by Kopierwichtel

mmh, strange, with the uploaded build its also not working, i used the sample also. Will attach the log.

Changed at 2016-10-18T19:28:25+01:00 by Kopierwichtel

comment:17 Changed at 2016-10-18T21:46:20+01:00 by afedchin

for full tab/sbs movies you need to change aspect manually.

@Fernet, can we change aspect for non anamorph stereo movies (i.e. full stereo pairs)? for tab *=2 and sbs /=2?

Before ffmpeg 3.x.x it was possible to change display width/height in mkv container and it works perfectly, but now we are using codec aspect that's wrong for non anamorph videos.

Last edited at 2016-10-19T08:51:42+01:00 by afedchin (previous) (diff)

comment:18 Changed at 2016-10-19T05:35:49+01:00 by FernetMenta

  • Resolution Fixed deleted
  • Status changed from closed to reopened

Sorry, I tried a different sample called "sample" :)

@afedchin I will submit a PR today. If AR is not specified explicitly by the codec's parmeters, we need to either *2 or /2 for TAB and SBS respectively.

comment:20 Changed at 2016-10-19T17:55:15+01:00 by Kopierwichtel

now its working again, checked it with a full sbs movie. Thanks for fixing :-)

comment:21 Changed at 2016-10-19T20:00:53+01:00 by Kopierwichtel

I noticed an issue in 3D mode when entering on the on screen menu. I started the video in 2D, pressed m, then switch to 3D. The button in the menu are displayed correctly. Then pressed m again to exit menu andf then again m to enter the menu again. The button width is now the half of the correct size.

But apart from that the video is fine.

Changed at 2016-10-19T20:03:52+01:00 by Kopierwichtel

after switching to 3D mode

Changed at 2016-10-19T20:04:26+01:00 by Kopierwichtel

after closing and reopening the on screen menu

comment:22 Changed at 2016-10-19T21:36:59+01:00 by afedchin

please create another ticket. seems it's estuary related I can't reproduce the same with other skin.

comment:23 Changed at 2016-10-22T08:05:29+01:00 by FernetMenta

  • Resolution set to Fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.