#16840 closed Bugs (Fixed)

"channelpreviewactive" apparently falsely stays true after the following scenario

Reported by: axbmcuser Owned by: mkortstiege
Priority: 4 - Normal
Component: PVR (Personal Video Recoder) - EPG TV-Guide Version:
Severity: Normal Keywords:
Cc: Blocked By:
Blocking: Platform: All

Description

Looks like "channelpreviewactive" stays true after the following scenario (which causes GUI problems while playing normal video-file content afterwards):

  • Setting ENABLED: "Confirm channel switches by pressing OK" (Settings > TV > Playback)
  • Start LiveTV-Playback
  • Make channelpreviewactive=true by selecting another channel _without_ really confirming switching to it
  • Stop LiveTV playback in the situation where channelpreviewactive still is true (by pressing STOP on your remote control for example)
  • Choose a normal movie video file (Non-LiveTV) from your library
  • Open VideoFullScreen (Info)
  • channelpreviewactive still is true although it should never be in such a normal video file playback situation
  • channelpreviewactive being still "true" while playing normal non-live-tv-video-files now causes some GUI items like video resolution info to be hidden as this bool is used in many skins

Tested on LibreELEC/Linux nightly and http://mirrors.kodi.tv/nightlies/win32/KodiSetup-20160807-450eecd-master.exe

Change History (3)

comment:1 Changed at 2016-08-09T23:42:42+01:00 by axbmcuser

I know it's not the default skin anymore, but Confluence has good conditions to easily reproduce this problem with the described steps.

Additional Info regarding step "Open VideoFullScreen (Info)" The problem is visible when openening the Info Dialog (without the player buttons!)

Last edited at 2016-08-09T23:45:57+01:00 by axbmcuser (previous) (diff)

comment:2 Changed at 2016-08-10T00:09:28+01:00 by axbmcuser

Seems that you can also make KODI crash with this steps:

  • Setting ENABLED: "Confirm channel switches by pressing OK" (Settings > TV > Playback)
  • Start LiveTV-Playback
  • Make channelpreviewactive=true by selecting another channel _without_ really confirming switching to it
  • Stop LiveTV playback in the situation where channelpreviewactive still is true (by pressing STOP on your remote control for example)
  • Choose and play a normal movie video file (Non-LiveTV) from your library
  • Open VideoFullScreen (by pressing I - Info Dialog - _without_ player buttons)
  • Press ENTER to switch from plain Info Dialog to full VideoOSD with player buttons
  • Instant crash

Again, because of his GUI-structure Confluence has best conditions to reproduce this.

http://pastebin.com/raw/vTEFAZke

Problem and crash disappears if Setting "Confirm channel switches by pressing OK" (Settings > TV > Playback) is set to DISABLED

Last edited at 2016-08-10T00:12:30+01:00 by axbmcuser (previous) (diff)

comment:3 Changed at 2016-08-10T18:02:16+01:00 by ksooo

  • Component changed from Graphical User Interface (GUI) to PVR (Personal Video Recoder) - EPG TV-Guide
  • Resolution set to Fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.