#16635 closed Bugs (Fixed)

Dynamically filled lists get stalled

Reported by: BobCratchett Owned by: BigNoid
Priority: 4 - Normal
Component: Graphical User Interface (GUI) Version: 17.0 "Krypton" Beta4
Severity: Normal Keywords: list, content, dynamic
Cc: Blocked By:
Blocking: Platform: All

Description

When using a list filled straight from a path - be that a node, plugin, etc - if the window it is on is closed before the list is filled, when the window is re-opened the list will be empty and Kodi won't make any attempt to load it again.

To reproduce, add a new window to Confluence or Estuary, with a list control in it.

Set the content to <content>videodb://movies/titles/</content> - or any other path that takes a few seconds to load.

Add a button to launch the window.

Open the window, immediately close it, then re-open. The list won't populate.

Refresh the skin or reload Kodi and open the window. The list will populate after a few seconds.

This issue has been confirmed on Jarvis and Krypton. Debug log attached - showing first opening, closing and re-opening the window (to show the issue), then reloading the skin and opening the window (to show the list works), and happy to provide further information.

Attachments (1)

kodi.log (107.8 KB) - added by BobCratchett at 2016-03-15T09:32:33Z.
Debug log

Change History (11)

Changed at 2016-03-15T09:32:33Z by BobCratchett

Debug log

comment:1 Changed at 2016-03-16T02:56:34Z by braz

I can confirm the issue, which is well explained by Bob. Thanks for looking into this!

comment:2 Changed at 2016-03-16T18:43:29Z by marcelveldt

I can confirm too, also happens on the homescreen. Move away from home before the widget with the dynamic path was actually fully loaded and it will stay empty even if returning to home.

comment:5 Changed at 2016-10-17T20:05:27+01:00 by Martijn

Please retry with a newer nightly version to confirm issue still exists

comment:6 Changed at 2016-10-17T21:33:58+01:00 by BobCratchett

I can confirm this issue is still reproducible with the latest nightly build for Mac.

comment:7 Changed at 2016-10-17T21:35:57+01:00 by Martijn

  • Milestone changed from Pending (only Team-Kodi changes this) to 17.0 "Krypton"
  • Version changed from 17.0 "Krypton" Alpha1 to 17.0 "Krypton" Beta4

comment:8 Changed at 2016-11-14T23:33:17Z by Razze

  • Owner changed from mkortstiege to BigNoid
  • Status changed from new to assigned

comment:9 Changed at 2016-11-15T09:21:50Z by BigNoid

See https://github.com/xbmc/xbmc/pull/10931 for a fix of this issue. With that change lists always load on window open.

comment:10 Changed at 2016-11-16T17:20:32Z by BobCratchett

Thanks for looking into this BigNoid. I can confirm with 10931 I'm unable to reproduce the issue :)

comment:11 Changed at 2016-11-17T02:28:08Z by braz

Great news, thanks all!

comment:12 Changed at 2016-11-17T06:44:30Z by BigNoid

  • Resolution set to Fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.