#16097 closed Bugs (Fixed)

Video Playback of TS live streaming files/urls over the internet

Reported by: reat0ide Owned by: FernetMenta
Priority: 4 - Normal
Component: Video playback (inc. audio in video and codecs) Version: 16.0 "Jarvis" Alpha1
Severity: Normal Keywords: Video playback
Cc: Blocked By:
Blocking: Platform: All

Description

Hi,

it seems that kodi is not be able to playback some ts file as live stream url, for example: http://x.x.x.x:123/test/test/sample.ts. In the log files there are some errors releated to curl, mime-type and demuxer.

Addon i used: pvr-simple-client, play-list-loader and directly as sample.strm

Kodi is able to play the TS file if it has been downloaded previously and saved as sample.ts

The problem appears on kodi Version 13, 14, 15 (osx, openelec).

Some Logs:

http://xbmclogs.com/pmyr5jjvu (from pvr-simple)

http://xbmclogs.com/pj6tdzyii (from playlist loader)

Sample file (sample.ts)

https://www.mediafire.com/folder/mj1dovx5vv3mv/kodi_log

Thanks

Change History (6)

comment:1 Changed at 2015-07-08T13:41:04+01:00 by reat0ide

As i can see in the logs, maybe the problem is related to Curlfile: CCurlFile::GetMimeType - http://x.x.x.x:56088/live/test1/test1/1.ts -> x-directory/normal.

comment:2 Changed at 2015-07-08T15:46:49+01:00 by FernetMenta

there is a pr which enables clients like pvr addons to prevent player from requesting mime type: https://github.com/xbmc/xbmc/pull/7407

comment:3 Changed at 2015-07-08T16:13:01+01:00 by reat0ide

It's already in Master? EDIT: sorry,i see, it's in pull request

Last edited at 2015-07-08T18:30:58+01:00 by reat0ide (previous) (diff)

comment:4 Changed at 2015-07-09T12:08:03+01:00 by reat0ide

Hi, i just compiled kodi-master with your commit on osx with xcode, but i don't see any difference, pvr simple-client still asking for mime:

http://xbmclogs.com/pde7kuj02

comment:5 Changed at 2015-07-09T17:46:59+01:00 by FernetMenta

I said it enables the addons. means they have to implement it

Last edited at 2015-07-09T17:47:14+01:00 by FernetMenta (previous) (diff)

comment:6 Changed at 2015-11-25T21:15:14Z by Razze

  • Resolution set to Fixed
  • Status changed from new to closed
  • Version changed from 14.2 "Helix" Final to 16.0 "Jarvis" Alpha1
Note: See TracTickets for help on using tickets.