#15825 closed Bugs (Fixed)

Raspberry DVDPlayer AC3 Passthrough

Reported by: Psyduckap Owned by: fritsch
Priority: 4 - Normal
Component: Audio playback (audio/video files) Version: 14.1 "Helix" Final
Severity: Normal Keywords: DVDPlayer AC3 Passthrough
Cc: FernetMenta, popcornmix, Anssi Blocked By:
Blocking: Platform: Other

Description

Hi.

I can't get ac3 passthrough with dvdplayer. With omxplayer the same files do passthrough.
I've tried with mkvs, BD Isos, and dvds.
All work ok with omxplayer but with dvdplayer I only get noise.
Other audio tracks in the files work well with dvdplayer. If I disable passthrough, ac3 tracks play in pcm 2.0

My setup: Raspberry pi B with Openelec 5.0.3 -> HDMI -> TV -> Optical -> Amplifier
Number of channels: 2
Changed Raspberry B with Raspberry 2 and it's the same
I think with Openelec 4.x was the same, at least with dvds

tvservice -a output:
PCM supported: Max channels: 2, Max samplerate: 48Khz, Max samplesize 24 bits
AC3 supported: Max channels: 6, Max samplerate: 48Khz, Max rate 640 kb/s

Maybe it's Sony related, in this thread http://forum.kodi.tv/showthread.php?tid=218913 we can't get passthrough with 3 different Sony tvs.

In the log I play the same file with OMXPlayer and DVDPlayer. The first works without issue and the second only outputs noise.

The file is Arrow 3x01 - La calma.mkv

If you need more information, please let me know.

Regards.

Attachments (2)

kodi.log (258.0 KB) - added by Psyduckap at 2015-03-01T13:39:44Z.
kodi2.log (77.7 KB) - added by Psyduckap at 2015-03-01T17:44:07Z.
File played with "adjust refresh rate to match video"

Change History (11)

Changed at 2015-03-01T13:39:44Z by Psyduckap

comment:1 Changed at 2015-03-01T14:02:21Z by FernetMenta

do you have another kodi system to test with? if not please try to disable "adjust refresh rate to match video"

Changed at 2015-03-01T17:44:07Z by Psyduckap

File played with "adjust refresh rate to match video"

comment:2 Changed at 2015-03-01T17:46:50Z by Psyduckap

No, I haven't another system
I've tried with "adjust refresh rate to match video" and the result is the same, noise.
I've uploaded another log. The file played is the same as before.

comment:3 Changed at 2015-03-03T09:17:03Z by Psyduckap

Just in case it's useful.
It seems to be sony related, here http://forum.kodi.tv/showthread.php?tid=218309 there are people who can do passthrough with other brand.

comment:4 Changed at 2015-03-07T10:53:42Z by dkscan

I am having the same problem with my Sony. For a test I tried passing through AC3 sound to a number of tv's: 3 different Sony's, 2 different Philips, 1 UMC and 1 Prosonic.

I tested with both OMXPlayer and DVDPlayer (MMAL).

Results:

OMXPlayer: The oldest Sony and the Prosonic stayed silent (tvservice -a confirmed, that they do not support AC3). The other tv's played sound ok.

DVDPlayer: Only the 2 Philips played ok. All the others produced noise only.

comment:5 Changed at 2015-03-07T11:10:28Z by FernetMenta

  • Cc popcornmix added

comment:6 Changed at 2015-03-07T11:13:30Z by fritsch

  • Cc Anssi added

comment:7 Changed at 2016-02-20T11:49:07Z by popcornmix

This has been reported as fixed with latest firmware update. http://forum.kodi.tv/showthread.php?tid=250817&pid=2251684#pid2251684

comment:8 Changed at 2016-02-20T17:07:56Z by dkscan

Replaced the .elf and .dat files on my RPI2 running OSMC and I can confirm that the noise problem has gone. Passthrough with MMAL now works with my Sony tv.

comment:9 Changed at 2018-05-11T14:41:32+01:00 by Rechi

  • Milestone changed from Pending / Future to 17.0 "Krypton"
  • Resolution set to Fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.