#15457 closed Bugs (Incomplete (need more info))

Subtitle not active on Blu-ray/iso playback

Reported by: delinend Owned by: Ace
Priority: 4 - Normal
Component: Subtitles Version: 14.0 "Helix" Alpha4
Severity: Normal Keywords:
Cc: Ace Blocked By:
Blocking: Platform: All

Description

When I playback Blu-ray/ISO movies, I have to "Activate" Subtitle on every movie (the small subtitle button, lower/right).... When I playback DVD/ISO movies, the default subtitle language is showing up fine.

I have just tryed, in the Audio OSD while playing a movie, to enable subtitles and then click on "Set as default for all videos. But if I stop and restart the Blu-ray/ISO, then the Subtitle enable flag is not saved. Even when I have set as default for all videos in the Audio OSD.

On DVD/ISO playback, the Subtitle is enabled in the Audio OSD.

It looks like the setting is not saved, on Blu-ray/ISO playback.

Same error on RPi OpenElec Helix and Last Kodi Helix Alpha 4 for Windows.

Change History (16)

comment:1 Changed at 2014-09-27T19:28:12+01:00 by Ace

  • Owner changed from elupus to Ace
  • Status changed from new to assigned

comment:2 Changed at 2014-09-28T11:24:48+01:00 by delinend

I have done some more testing....:

For windows:
Gotham 13.2 it is working.
Helix 14 alpha 2 NOT working.
Helix 14 alpha 3 NOT working.
Helix 14 alpha 4 NOT working.

For Raspberry (OPENelec):
Helix 14 alpha 3 with Newclock3 it is working.
Helix 14 alpha 3 with Newclock4 NOT working.
Helix 14 alpha 4 with Newclock4 NOT working.

I know that it's not the same player, as I force omxplayer on the RPi. I have allso pushed the issue off newclock4 in the RPi group of OPENelec.

Last edited at 2014-09-28T11:25:47+01:00 by delinend (previous) (diff)

comment:3 Changed at 2014-09-28T17:58:17+01:00 by delinend

Popcornmix, can confirme that from Newclock4, he use the new merged omxplayer/dvdplayer build. So thats why the issue came into RPi, from the dvdplayer.

comment:4 Changed at 2014-10-02T09:37:11+01:00 by Ace

It works for me on resume. What are the exact steps to reproduce?

comment:5 Changed at 2014-10-02T10:16:14+01:00 by delinend

If I start a new Bluray/iso movie, I first get the "Select playback item", where I press "Play main title: 0"

And then the movie starts without subtitle. I then goes down to the OSD Audio menu/button, and enable "Enable subtitles". And then the subtitle works. I allso press the "Set as default for all videos" in the Audio OSD menu.

If I then stop the movie, and start it again "Start from beginning" or "Resume from xx:xx:xx" then the "Enable subtitle" flag is disabled again (not saved).

Everything works fine on DVD/ISO playback. I only see the problem with Bluray/ISO files.

comment:6 Changed at 2014-10-20T16:27:49+01:00 by delinend

Any news, or something I can help with ? I still see the same issue, on last Helix build 14.0-ALPHA5 Git:8e4bfa7

comment:7 Changed at 2014-11-01T17:46:46Z by delinend

If I try to enable Subtitle as default, in the OSD/audio menu, I see this in my log: http://pastebin.com/bKqGPQdN

comment:8 Changed at 2014-12-08T19:51:47Z by delinend

Any news about this old error ? I see many more reporting on this problem.. Still same error in 14.0-RC2 git20141207

See also this: http://trac.kodi.tv/ticket/15592

comment:9 follow-up: Changed at 2014-12-11T15:47:15Z by Ace

Resume only works by chance if the longest title (which is the main title sometimes) is resumed directly, i.e., no menus are involved.

The problem is, that we don't store the current title etc. on stop. For dvds we store the complete player state for resume. I'm not sure whether we need this for blurays too or not.

A quick fix, or a first step into the right direction, would be to store the title number and disable menus on resume.

comment:10 in reply to: ↑ 9 Changed at 2014-12-11T16:49:26Z by delinend

Replying to Ace:

Resume only works by chance if the longest title (which is the main title sometimes) is resumed directly, i.e., no menus are involved.

The problem is, that we don't store the current title etc. on stop. For dvds we store the complete player state for resume. I'm not sure whether we need this for blurays too or not.

A quick fix, or a first step into the right direction, would be to store the title number and disable menus on resume.

The head problem is not on resume.... The default subtitle is NOT startet/enabled on Blu-ray/ISO playback ! If I start a DVD/ISO the default subtitle is startet/enabled, and Works great. But this do not Work on Bly-ray/ISO playback anymore, from Helex Newclock4. And it's not possibel to safe the Subtitle ON, in the Audio OSD. If I start another Blu-ray/ISO movie, the subtitle flag in Audio OSD, if OFF Again (not saved).

comment:11 follow-up: Changed at 2014-12-12T19:10:16Z by Ace

If you set Blu-ray playback mode to play main movie it should work. So it's related to the menu mode.

comment:12 in reply to: ↑ 11 Changed at 2014-12-12T21:28:12Z by delinend

Replying to Ace:

If you set Blu-ray playback mode to play main movie it should work. So it's related to the menu mode.

I have tried that... And if I Playback another Blu-ray/ISO and then go back to Playback the first Blu-ray/ISO again, then the Subtitle is gone Again :-(

comment:13 Changed at 2015-01-25T19:57:36Z by delinend

This problem is still in version 15.0alpha git:20150123 Default Bluray ISO subtitles is NOT starting on playback !!! We have to manuel start subtitles eatch time, we start a new Bluray ISO playback. And we can't save this as Default for all video's.

Can please someone fix or look into this issue, that is very old noq... The problem came with newclock4.

Best regards

Last edited at 2015-01-25T20:06:10Z by delinend (previous) (diff)

comment:14 Changed at 2015-01-28T16:44:15Z by delinend

  • Cc changed from Ace, to Ace

Hi again.

I have just made a Video, where I show the problem, with default subtitle playback, on Blu-ray ISO's, after Newclock4. https://www.youtube.com/watch?v=XZ2tJADbhHQ

comment:15 Changed at 2015-06-23T16:00:46+01:00 by Ace

Is this a forced or external subtitle? Can you post the output of mediaInfo?

comment:16 Changed at 2015-11-23T19:14:29Z by Razze

  • Resolution set to Incomplete (need more info)
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.