#16673 closed Bugs (Fixed)

Trac not working with firefox

Reported by: daniello Owned by:
Priority: 4 - Normal
Component: > Choose specific component Version:
Severity: Normal Keywords:
Cc: Blocked By:
Blocking: Platform: Other

Description

When I login I get: "Fehlender oder ungültiger Prüfschlüssel. Haben Sie Cookies aktiviert?" Currently v45.0.1

Works with Chrome though if I remember well I wasn't able to upload an attachment wich Chrome.

Change History (8)

comment:1 Changed at 2016-04-08T18:44:57+01:00 by l-37

Clear your cookies in Firefox, then it should work, also see:

We are experiencing a weird issue with login cookies, but incognito mode in your browser should work just fine.

Attachments don't work at all due to a server error (IndexError: pop from empty list), it has nothing to do with your browser.

comment:2 Changed at 2016-04-08T19:05:34+01:00 by daniello

cleared trac.kodi.tv cookie, restarted FF .. still same error message.

comment:3 Changed at 2016-04-08T19:14:55+01:00 by l-37

Clearing cookies from trac.kodi.tv DOES NOT SUFFICE.

You have to clear all cookies from kodi.tv, because the cookies from the forum are actually the ones that create the issue.

Chrome only works for you because you did not log into the forum with Chrome.

comment:4 Changed at 2016-04-09T06:51:07+01:00 by daniello

Thanks .. works now. Has been like that for long .. I wonder why nobody bothers. Not being able to login and not being able to upload are IMO serious issues ;-)

comment:5 Changed at 2016-04-09T11:13:13+01:00 by spoyser

Might be worth making this issue and solution more public as this is an issue on both Linux and Windows with Chrome, Firefox, Internet Explorer 11 (and possibly more)

See also here:

http://forum.kodi.tv/showthread.php?tid=266860

comment:6 Changed at 2016-04-10T16:43:19+01:00 by l-37

Regarding the cookie issue:
Both trac and the forum have to be configured to use their respective domain, instead of setting cookies for .kodi.tv, causing the cookie name clash.

This can be done in Trac, by setting auth_cookie_domain to trac.kodi.tv [1] and in MyBB by setting the cookie domain to forum.kodi.tv [2]. Once both Trac and MyBB are properly configured to use the correct domain for the cookies, this issue will be gone.

Regarding the file attachment problem:
This appears to be a bug in German and Hungarian translation as per [3] and you can work around it by switching Trac to english [4].

[1] https://trac.edgewall.org/wiki/TracIni
[2] http://docs.mybb.com/1.8/development/cookies/#cookie-domain
[3] https://trac.edgewall.org/ticket/11184#comment:30
[4] http://trac.kodi.tv/prefs/language

comment:7 Changed at 2016-05-27T11:23:15+01:00 by Kib

Made modification to trac.kodi.tv cookie settings. I believe it is working now, but it still requires to remove the old cookies if you have them.

Thanks for doing the legwork on this because I couldn't find that (non-standard!) setting.

comment:8 Changed at 2016-10-03T06:45:06+01:00 by Kib

  • Resolution set to Fixed
  • Status changed from new to closed

Confirmed working after cookies have been fixed on both the forum and trac.

If you experience this problem please delete the cookie for forum.kodi.tv and the cookie for trac.kodi.tv and all should start to work again.

Note: See TracTickets for help on using tickets.