Opened 17 months ago

Closed 17 months ago

Last modified 16 months ago

#14998 closed Bugs (Fixed)

Crash when playing wma audio file

Reported by: emuujay Owned by: fritsch
Priority: 4 - Normal Milestone: 13.0 "Gotham"
Component: Audio playback (audio/video files) Version: 13.0 "Gotham" Alpha10
Severity: Normal Keywords:
Cc: fritsch, FernetMenta, Blocked By:
Blocking: Platform: All
Revision:

Description

I am using 13.0 Gotham Beta (there does not seem to be a version for this in the drop down below?) on Windows 7.

I am experiencing a C++ runtime error when trying to play a wma file (see screenshot and debug log attached). To reproduce, I only have to launch XBMC, navigate to the Music->Files view and select any wma file to play. This seems to happen irrespective of whether the file is in my library or not.

For reference, I see similar behaviour when using OpenELEC 4.0 Beta on Raspberry Pi - when I attempt to play a wma audio file the XBMC application crashes and is then restarted.

Attachments (3)

xbmc.log (54.1 KB) - added by emuujay 17 months ago.
XBMC debug log
Runtime error.png (290.0 KB) - added by emuujay 17 months ago.
Runtime error screenshot
10 Harvey the Wonder Hamster.wma (368.1 KB) - added by emuujay 17 months ago.
wma file which causes crash for me

Download all attachments as: .zip

Change History (14)

Changed 17 months ago by emuujay

XBMC debug log

Changed 17 months ago by emuujay

Runtime error screenshot

comment:1 Changed 17 months ago by emuujay

Apologies, I seem to have submitted this as an "android specific feature" under "component" when I have, in fact, witnessed it on both Windows and Raspberry Pi (through OpenELEC). Please excuse this - this was my first bug report!

comment:2 Changed 17 months ago by Koying

  • Cc fritsch FernetMenta added
  • Component changed from Android specific feature to Audio playback (audio/video files)
  • Owner changed from Koying to fritsch

comment:3 Changed 17 months ago by emuujay

I forgot to mention, this is with a clean install of XBMC, with clean settings folder (I manually verified the settings folders had been deleted). The only change from the application as installed is the advancedsettings.xml options which are shown in the log file.

Last edited 17 months ago by emuujay (previous) (diff)

comment:4 Changed 17 months ago by FernetMenta

I can't reproduce here with my wma files. Please provide a sample.

Changed 17 months ago by emuujay

wma file which causes crash for me

comment:5 Changed 17 months ago by emuujay

I have attached a wma file which causes this for me. Hope this helps you reproduce!

comment:6 Changed 17 months ago by FernetMenta

a ffmpeg backport fixes the issue: https://github.com/xbmc/xbmc/pull/4375

comment:7 Changed 17 months ago by emuujay

Awesome - thanks very much for the quick responses! Will this now be available in the nightly build tonight?

comment:8 Changed 17 months ago by FernetMenta

depends on whether the release managers pull it. check the status of the pull request.

comment:9 Changed 17 months ago by emuujay

Ah - that makes sense! Thanks for the debug effort (and the patience)!

comment:10 Changed 17 months ago by FernetMenta

  • Resolution set to Fixed
  • Status changed from new to closed

comment:11 Changed 16 months ago by Martijn

  • Milestone changed from Future / Pending to 13.0
Note: See TracTickets for help on using tickets.