Ticket #14500 (closed Bugs: Fixed)

Opened 17 months ago

Last modified 16 months ago

regular crashing accessing a specific menu.

Reported by: Martijn Owned by: arnova
Priority: 4 - Normal Milestone: 13.0 "Gotham"
Component: Graphical User Interface (GUI) Version: GIT
Severity: Normal Keywords:
Cc: jfcarrol Blocked By:
Blocking: Platform: Linux
Revision:

Description

XBMC crashes on regular interval for some while now accessing random menus and was never able to repro it. finally i got lucky and could reproduce it time and time again here's the crashlog  http://sprunge.us/EabI

so for tracking purpose. according to jcarrol: jcarroll Thread 10 is where it crashed 19:28 jcarroll in sqllite 19:28 jcarroll it's in the connect call 19:30 jcarroll twice 19:30 jcarroll :-) 19:30 jcarroll Thread 1 AND Thread 10 19:31 jcarroll i'm guessing it's not thread safe

Change History

comment:1 Changed 16 months ago by arnova

  • Owner changed from jfcarroll to arnova
  • Status changed from new to assigned
  • Milestone changed from Future / Pending to 13.0

comment:2 Changed 16 months ago by Github Janitor

  • Status changed from assigned to closed
  • Resolution set to Fixed

fixed: Crash in Pictures caused by PR2890 (fixes #14500)

Changeset: 948f09e7535095887c1649db1cdd7fccea7b3ac3 By: arnova

Note: See TracTickets for help on using tickets.