Ticket #13515 (closed Bugs: Fixed)

Opened 2 years ago

Last modified 2 years ago

Teletext/Videotext display issue

Reported by: h3llsp4wn Owned by:
Priority: 4 - Normal Milestone: 12.0 "Frodo"
Component: PVR (Personal Video Recoder) - core components Version: GIT
Severity: Normal Keywords: teletext, videotext
Cc: opdenkamp Blocked By:
Blocking: Platform: Windows
Revision:

Description

If you turn on teletext/videotext in PVR the text information is being displayed, but the background is either transparent or has the wrong background color. Therefore it's a mess to read the text.

Tried different PVRs - it seems to be and XBMC issue introduced somewhere in September.

Attachments

screenshot.png Download (1.2 MB) - added by h3llsp4wn 2 years ago.

Change History

comment:1 Changed 2 years ago by jmarshall

  • Cc opdenkamp added

Changed 2 years ago by h3llsp4wn

comment:2 Changed 2 years ago by h3llsp4wn

Just to add - it`s in Beta 1 now.

comment:3 Changed 2 years ago by Japaja

Still there in Beta 2.

comment:4 Changed 2 years ago by margro

It took quite some time to find the cause, but I figured out that it is broken since june 2012.

This pull request should fix this problem.  https://github.com/xbmc/xbmc/pull/1906

comment:5 Changed 2 years ago by Github Janitor

  • Status changed from new to closed
  • Resolution set to Fixed

teletext: fixes #13515 transparent background issue on Windows systems This regression was introduced in commit 424a4d98877a1da4f7d33e006504c2830225fb71: the removal of SDL for Windows. This removed the HAS_SDL define and it turns out that the replacement SDL_memset4 define behaves different than the one from the SDL_stdinc.h header This change implements the SDL_memset4 replacement to match the SDL original.

Changeset: 54dbf3419f0d2c2de89ada6eeb122b08965607e1 By: Marcel Groothuis

comment:6 Changed 2 years ago by Github Janitor

Merge pull request #1906 from margro/fixtrac13515

teletext: fixes #13515 transparent background issue on Windows systems

Changeset: 7f49891d0a13de807e7da80daa2167a77680c5ce By: davilla

comment:7 Changed 2 years ago by sho

  • Milestone changed from Future / Pending to 12.0
Note: See TracTickets for help on using tickets.