Ticket #13191 (closed Bugs: Incomplete (need more info))

Opened 2 years ago

Last modified 11 months ago

XBMC player does not play audio in FLV stream

Reported by: ecinema Owned by:
Priority: 4 - Normal Milestone:
Component: Video playback (inc. audio in video and codecs) Version: GIT
Severity: Normal Keywords: audio stream rtmpdump
Cc: elupus, DDDamian, Blocked By:
Blocking: Platform: All
Revision:

Description

The video generated by rtmpdump does not play with audio in XBMC. The same file play correctly with audio in any other player. Tested in xbmcubuntu and xbmc under windows and show the same bug Sample file:  http://www.filedropper.com/kiss Mediainfo details General Complete name : D:\rtmpdump\kiss.flv Format : Flash Video File size : 669 KiB Duration : 4s 181ms Overall bit rate : 1 310 Kbps _width : 768.000 _height : 572.000 _fps : 25.000

Video Format : AVC Format/Info : Advanced Video Codec Format profile : Baseline@L3.0 Format settings, CABAC : No Format settings, ReFrames : 3 frames Codec ID : 7 Duration : 140ms Width : 768 pixels Height : 572 pixels Display aspect ratio : 4:3 Frame rate mode : Variable Standard : PAL Color space : YUV Chroma subsampling : 4:2:0 Bit depth : 8 bits Scan type : Progressive Color primaries : BT.709-5, BT.1361, IEC 61966-2-4, SMPTE RP177 Transfer characteristics : BT.709-5, BT.1361 Matrix coefficients : BT.709-5, BT.1361, IEC 61966-2-4 709, SMPTE RP177

Audio Format : AAC Format/Info : Advanced Audio Codec Format profile : LC Codec ID : 10 Duration : 4s 181ms Channel(s) : 2 channels Channel positions : Front: L R Sampling rate : 48.0 KHz Compression mode : Lossy

Attachments

kiss.flv Download (668.6 KB) - added by ecinema 2 years ago.
rtmpdump stream sample that does not play with sound in XBMC

Change History

Changed 2 years ago by ecinema

rtmpdump stream sample that does not play with sound in XBMC

comment:1 Changed 2 years ago by ecinema

Tested also with xbmc 12 alpha3 and the result is the same No Audio File plays fine in VLC

comment:2 Changed 2 years ago by Martijn

  • Priority changed from 4 - Normal to 3

if possible try to replicate using a latest nightly build so we can see if this is still an issue for upcoming release.  http://mirrors.xbmc.org/nightlies/

Make sure you backup your userdata folder before doing so or test on a separate machine

comment:3 Changed 2 years ago by ecinema

the reason that it does not play is because first audio packet which contains details about the audio stream is 20 bytes instead of 4 bytes and XBMC player does not like that.

comment:4 Changed 2 years ago by sho

  • Cc elupus, DDDamian, added
  • Priority changed from 3 to 4 - Normal
  • Version changed from 11.0 "Eden" to GIT

Confirmed on master, not AE related?

comment:5 Changed 2 years ago by eprst

RC3 and latest nightlies (XBMCSetup-20130125-8ce3d54-master) don't play this file at all, looks like decoder thread hangs. I can attach another example if needed.

comment:6 Changed 17 months ago by Martijn

if possible also try out a nightly build, we need to know if it's still happening with current code so we could possibly fix it for next release). Always backup your userdata.

report if still happens

comment:7 Changed 12 months ago by Martijn

  • Status changed from new to closed
  • Resolution set to Incomplete (need more info)

please retry using the lasted XBMC Gotham nightly build if problem still persist.  http://mirrors.xbmc.org/nightlies/ There will be no more fixes for Frodo builds.

Backup up your userdata to be safe. If problem persist please report back. Closing it for now.

comment:8 Changed 11 months ago by Martijn

  • Milestone Future / Pending deleted
Note: See TracTickets for help on using tickets.