Opened 3 years ago

Closed 3 years ago

#13133 closed Bugs (Incomplete (need more info))

Video playback stop when playing mpeg-ts container files

Reported by: tsp42 Owned by:
Priority: 3 Milestone:
Component: Video playback (inc. audio in video and codecs) Version: GIT
Severity: Normal Keywords: mpeg-ts
Cc: elupus, Blocked By:
Blocking: Platform: All
Revision: 3d4ab0b0afb37e0d779093e231d6676e3fe1b3af


playback of mpeg-ts files eventially stalls with the progress bar alterating +/- 1 second. The bug was first reported on opdenkamps pvr branch ( but is reproducible in main as well. A sample clip is available ( To reproduce seek to 0:30, press rewind and then press play at 0:17. Pastebin log available here (

Change History (5)

comment:1 Changed 3 years ago by dteirney

  • Cc elupus added

@elupus, the log for this is slightly different to the "go slow mode" I was experiencing in #12984 but the general outcome appears to be the same.

Is it possible that the same thing could be triggered by a normal seek as well as a non-flushed seek?

All the files I have had problems with have also been mpeg-ts files.

comment:2 Changed 3 years ago by dteirney

comment:3 Changed 3 years ago by FernetMenta

I have tracked this further down. ffmpeg does not observe the overflow of the 33bit pcr timestamp. ff_gen_search bails out with no error because timestamps at the end of a file get smaller.

@elupus Any idea how to get this fixed?

comment:4 Changed 3 years ago by Martijn

  • Priority changed from 4 - Normal to 3

please retry using a latest XBMC master build if you still have this issue

comment:5 Changed 3 years ago by Martijn

  • Milestone Future / Pending deleted
  • Resolution set to Incomplete (need more info)
  • Status changed from new to closed

Since there was no reply from reporter tickets will be closed.

Please try latest XBMC testing versions that can be downloaded here

If issue is still present add comment to the ticket and include as much information as possible including a full debuglog Also read the FAQ and backup your userdata when upgrading

Note: See TracTickets for help on using tickets.