Ticket #12267 (closed Bugs: Fixed)

Opened 3 years ago

Last modified 18 months ago

.ts file playing stops, when try to jump forward.

Reported by: piipes Owned by:
Priority: 4 - Normal Milestone: 12.0 "Frodo"
Component: Video playback (inc. audio in video and codecs) Version: GIT
Severity: Normal Keywords:
Cc: Blocked By:
Blocking: Platform: All
Revision:

Description

No crashing, file play just stop. And that happens only some files. All other players play those files ok.

 http://pastebin.com/d1GWRCjh

Change History

comment:1 Changed 3 years ago by ibydos

Hi,
I have exactly the same problem.

Playing 00001.ts will play just fine until I press "UP" what should seek +10 Minutes.
Playback suddenly stops at jumping +10Minutes (UP Button) or jumping +30sec (RIGHT Button).


Other Players I have tried:
MPC-HC: Length is 01:05:38 -> OK, Playback OK, Jumping in file OK
VLC: Length is 00:00:00 -> BROKEN, Playback OK, Jumping in file OK

So as other players can play it just fine, hopefully someone is able to fix xbmc to do so.


LOG:
 http://pastebin.com/raw.php?i=75Gt2YzU

FILE TO REPRODUCE:
 http://176.9.79.226/00001.ts
The file was recorded with vdr-1.7.21 (DVB-S)
Maybe the header or the stream itself is corrupted
Size: 3.3GB / Length: 01:05:38


MY SYSTEM:

ASUS AT3N7A-I (Intel Atom 330, 2x 1.60GHz + nVIDIA GeForce 9400)
XBMC 11.0-BETA2 (Eden) VDPAU Enabled
ARCH: LINUX 2.6.31-22-generic (Ubuntu 9.10 32bit)

comment:2 Changed 3 years ago by piipes

Do you need sample file? I can upload 1.7Gb .ts

comment:3 Changed 3 years ago by piipes

Do you have any time to look this issue?

comment:4 Changed 3 years ago by sho

  • Version set to GIT
  • Component changed from Other (un-categorized) to Video playback (inc. audio in video and codecs)

Can you please retest with a new nightly build? I suspect this might be fixed with the ffmpeg bump.

comment:5 Changed 3 years ago by piipes

No, nothing is not change. I test this version:  http://mirrors.xbmc.org/nightlies/win32/XBMCSetup-20120506-ef51d7a-master.exe

I can send you sample file if you need, but it is big. 1.5G I have 5M upload, it take sometime.

comment:6 Changed 3 years ago by piipes

Do you need that sample file? This bug is very evil. Have to change different program for those files.

comment:7 Changed 2 years ago by piipes

Here is latesr nightlies log. Same issue is still here.  http://pastebin.com/r2DV85QY

comment:8 Changed 2 years ago by cfetzer

axmhari has a fix for this:  https://github.com/xbmc/xbmc/commit/8261ee0. I tested the attached file. Length is shown as 01:04:59 and it seeks perfectly fine.

See also the discussion here  https://github.com/xbmc/xbmc/pull/1655. But be aware that the PR itself does not (yet) contain the proper fix.

comment:9 Changed 2 years ago by piipes

Ok, i will try it later.

Maybe that lenght issue is gone too. I have many .ts files, where video lengt is shown wrong. Right lengt is example 55min and i can see over 12hours. Seek is ok with those files.

comment:10 follow-up: ↓ 11 Changed 2 years ago by ibydos

I can confirm that this fix is working for me. Thanks for the info on this!

comment:11 in reply to: ↑ 10 ; follow-up: ↓ 12 Changed 2 years ago by piipes

Replying to ibydos:

I can confirm that this fix is working for me. Thanks for the info on this!

What version you try? Wont work latest nightlies. XBMCSetup-20121105-2330a44-master

 http://pastebin.com/z8wHzMxJ

comment:12 in reply to: ↑ 11 Changed 2 years ago by ibydos

Replying to piipes:

Replying to ibydos:

I can confirm that this fix is working for me. Thanks for the info on this!

What version you try? Wont work latest nightlies. XBMCSetup-20121105-2330a44-master

 http://pastebin.com/z8wHzMxJ

You have to replace "/lib/ffmpeg/libavformat/utils.c" with this version:  https://raw.github.com/xbmc/xbmc/8261ee095436ebed26c38ed85d4742deadbd6e5c/lib/ffmpeg/libavformat/utils.c

Then compile.

I tried it with latest git under ubuntu 12.04 LTS.

Its not yet in the nightlies.

Best, ibydos

comment:13 Changed 2 years ago by piipes

Not sure if this is different issue? But I still have the same problem with win7 32bit and latest nightlies. No problem with dvbviewer. Here is log.

 http://pastebin.com/qhE4iQyQ

comment:14 Changed 2 years ago by cfetzer

I think this can be closed as fixed ( https://github.com/xbmc/xbmc/pull/1655). The PR has been merged on 13/12/2012.

comment:15 Changed 2 years ago by sho

  • Status changed from new to closed
  • Resolution set to Fixed
  • Milestone changed from Future / Pending to 12.0

comment:16 Changed 19 months ago by piipes

Have to lift this up. This issue is still here. Seeking wont work. Same problem with latest beta and stable relase.

 http://pastebin.com/bKx6ZrAk

It only happens with mtv3 ava recordings. That channel use dvbsubtitles.

 http://japesone.kapsi.fi/loadfile.php?prefix=mediainfo.txt

comment:17 Changed 19 months ago by piipes

Please let me know, if you need full size .ts sample.

comment:18 Changed 18 months ago by piipes

No change here?

Note: See TracTickets for help on using tickets.